System Status

Dropbox Help Center and Blog are down
Incident Report for Dropbox
Resolved
We’re back! Help Center and Blog should be up and running. Thanks for bearing with us.
Posted Mar 19, 2021 - 16:46 UTC
Investigating
Our engineers are working to fix this problem. The Blog has been restored, and the Help Center should be back up shortly. Check back for an update soon.
Posted Mar 19, 2021 - 16:20 UTC
Identified
Dropbox Help Center and Blog are down for most users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Mar 19, 2021 - 15:50 UTC
This incident affected: Website.