Dropbox System Status

Paper is down for most users

Incident Report for Dropbox

Resolved

We’re back! Paper should be up and running. Thanks for bearing with us.
Posted Jul 09, 2021 - 23:16 UTC

Identified

Paper is down for most users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Jul 09, 2021 - 21:02 UTC
This incident affected: Paper.