Dropbox Service Disruption
Incident Report for Dropbox
Resolved
One of our payment providers suffered a DNS outage (most likely as part of an Internet-wide DDoS issue) causing Dropbox not to be able to process new payments for a short time. This issue was quickly resolved. Access to product features and/or user data was not impacted.
Posted 10 months ago. Oct 21, 2016 - 18:37 UTC
Investigating
Dropbox is currently experiencing a service disruption.

Our engineering team is working to identify the root cause and implement a solution as quickly as possible. Many users may be affected.

We apologize for the inconvenience and will send an additional update in 30 minutes.
Posted 10 months ago. Oct 21, 2016 - 17:55 UTC