System Status

Photo previews are not loading for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Feb 23, 2023 - 03:13 UTC
Investigating
Photo previews are not loading for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly
Posted Feb 23, 2023 - 02:39 UTC
This incident affected: Mobile Application.