System Status

Partial outage on Dropbox website
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Feb 14, 2022 - 00:45 UTC
Identified
The Dropbox website is experiencing a partial outage. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Feb 13, 2022 - 23:52 UTC
This incident affected: Website.