System Status

Uploading files on web might not be working for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Jul 01, 2023 - 04:56 UTC
Investigating
Uploading files on web might not be working for some users. We’re working to fix the problem as quickly as we can.
Posted Jul 01, 2023 - 04:36 UTC
This incident affected: Website.