System Status

Dropbox is performing routine maintenance
Incident Report for Dropbox
Resolved
We’re back up and running. Thanks for bearing with us.
Posted May 02, 2020 - 01:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 02, 2020 - 01:16 UTC
Investigating
Dropbox is performing routine maintenance across all parts of our platform. You may experience some delays, but we’ll have things back up and running as soon as possible to minimize disruption to you.
Posted May 02, 2020 - 00:41 UTC
This incident affected: Website, Desktop Application, Mobile Application, API, Paper, and Showcase.