Header for large screens Header for small screens

Dropbox Chat unavailable

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 21:11 UTC

Investigating

Dropbox Chat is currently unavailable, we are investigating the issue.
Posted Nov 14, 2025 - 20:00 UTC
This incident affected: Website, Desktop Application, Mobile Application, and Support Services.