Header for large screens Header for small screens

Scheduled maintenance

Incident Report for Dropbox

Resolved

Resolved! Dropbox is back up and running. Thank you for bearing with us.
Posted Jul 29, 2021 - 00:24 UTC

Investigating

Dropbox is performing routine maintenance. You may not be able to access Dropbox for a short period of time, but we’ll have things back up and running as soon as possible to minimize disruption to you.
Posted Jul 28, 2021 - 23:27 UTC
This incident affected: Website, Desktop Application, Mobile Application, API, Paper, and Passwords.