System Status

Dropbox may not be working as expected
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Apr 11, 2023 - 15:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2023 - 14:19 UTC
Identified
Dropbox is not working as expected for some users. We've identified and are working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Apr 11, 2023 - 13:58 UTC
This incident affected: Website.