System Status

Most customers are not able to access Dropbox
Incident Report for Dropbox
Resolved
We're back! This incident is now resolved, thank you for bearing with us!
Posted Aug 15, 2020 - 03:59 UTC
Update
We are continuing to investigate this issue.
Posted Aug 15, 2020 - 03:29 UTC
Investigating
Dropbox is currently down for most users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Aug 15, 2020 - 03:28 UTC
This incident affected: Website, Desktop Application, Mobile Application, API, Paper, and Showcase.