Paper Service Disruption
Incident Report for Dropbox
Resolved
Paper service has been fully restored. You may experience some latency with Paper tasks, but rest assured that normal performance will resume shortly. We apologize for any inconvenience this may have caused.
Posted over 1 year ago. Jun 13, 2017 - 01:05 UTC
Investigating
Paper is currently experiencing a service disruption.

Our engineering team is working to identify the root cause and implement a solution as quickly as possible. Some users may be affected.

We apologize for the inconvenience and will send an additional update soon.
Posted over 1 year ago. Jun 13, 2017 - 00:31 UTC