System Status

Some features are not working correctly on our website
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Dec 07, 2021 - 22:18 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 07, 2021 - 21:52 UTC
Investigating
We’re having some trouble with our website and payment processing. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Dec 07, 2021 - 21:26 UTC
This incident affected: Website.