System Status

Dropbox is not working as expected for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Jun 30, 2023 - 21:00 UTC
Investigating
Dropbox is not working as expected for some users. We're working to fix the problem as quickly as we can.
Posted Jun 30, 2023 - 20:51 UTC
This incident affected: Website, Desktop Application, and API.