Dropbox is experiencing an outage
Incident Report for Dropbox
Resolved
We’re back! Dropbox should be up and running. Thanks for bearing with us.
Posted 11 months ago. Mar 22, 2018 - 00:50 UTC
Investigating
Most parts of the Dropbox platform are experiencing an outage. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted 11 months ago. Mar 22, 2018 - 00:16 UTC