System Status

Copying and deleting actions are timing out for some users.
Incident Report for Dropbox
Resolved
This issue has been resolved.
Posted Jul 28, 2023 - 21:11 UTC
Investigating
Copying and deleting actions may not be working as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Jul 28, 2023 - 18:42 UTC
This incident affected: Website and Mobile Application.