System Status

Dropbox is experiencing an outage
Incident Report for Dropbox
Resolved
We're back! Everything should be up and running again. Thanks for your patience with us.
Posted 12 months ago. Aug 25, 2018 - 10:04 UTC
Investigating
All parts of the Dropbox platform are currently unavailable. We're working to fix the problem as soon as we can and we'll provide another update shortly.
Posted 12 months ago. Aug 25, 2018 - 09:42 UTC
This incident affected: Website.