System Status

Plans page may not be working as expected for some users on mobile.
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 04:18 UTC
Identified
Dropbox plans page might not be loading for some users on mobile.
Posted Jun 28, 2022 - 23:10 UTC
This incident affected: Website.