System Status

Dropbox is experiencing some issues
Incident Report for Dropbox
Resolved
This incident is resolved.
Posted Apr 19, 2022 - 21:13 UTC
Identified
We have identified the issue and are implementing a fix.
Posted Apr 19, 2022 - 20:51 UTC
Investigating
Our engineering team is working to identify the root cause and implement a solution as quickly as possible. Thank you for your patience.
Posted Apr 19, 2022 - 20:28 UTC
This incident affected: Website.