System Status

Editing documents with Microsoft apps may not be working for some Android users.
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Jul 05, 2023 - 18:40 UTC
Identified
Editing documents with Microsoft apps may not be working for some Android users. We have identified the issue and are working to fix as quickly as possible.
Posted Jul 05, 2023 - 14:49 UTC
This incident affected: Mobile Application.