Header for large screens Header for small screens

Some features are not working correctly on our website

Incident Report for Dropbox

Resolved

Thanks for your patience. This incident has been resolved.
Posted May 20, 2022 - 05:37 UTC

Identified

Some users may be having trouble navigating to Paper on the Dropbox website. We have identified the root cause and a fix is being implemented.
Posted May 20, 2022 - 01:03 UTC
This incident affected: Website.