Intermittent Loading Issues on Dropbox Website

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted May 23, 2025 - 20:24 UTC

Identified

Some users may experience longer than usual load times on the Dropbox website. We are actively investigating and working to resolve the issue.
Posted May 23, 2025 - 19:31 UTC
This incident affected: Website.