System Status

Signatures may not be working as expected for new users

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted 1 year ago. Apr 26, 2024 - 15:10 UTC

Investigating

Signatures may not be working as expected for new users on Dropbox accounts. We are working to resolve the issue as quickly as possible and will provide another update shortly.
Posted 1 year ago. Apr 26, 2024 - 13:46 UTC
This incident affected: Website.