System Status

Dropbox SSO is not working for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 22:06 UTC
Investigating
Dropbox SSO is not working for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Oct 13, 2022 - 21:21 UTC
This incident affected: Mobile Application.