Header for large screens Header for small screens

Dropbox website and other services may not be working as expected

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted Dec 12, 2022 - 19:37 UTC

Investigating

We are currently investigating the timing out of some Dropbox services.
Posted Dec 12, 2022 - 19:09 UTC
This incident affected: Website and API.