System Status

Issue downloading single files on safari 18.4

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted 25 days ago. Apr 10, 2025 - 07:53 UTC

Identified

We are aware some people are experiencing an issue downloading single files on safari 18.4. We are working to resolve this.
Posted 25 days ago. Apr 09, 2025 - 19:58 UTC
This incident affected: Website.