System Status

Enterprise console may not be working as expected

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted 10 months ago. Jun 18, 2024 - 16:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted 10 months ago. Jun 18, 2024 - 16:03 UTC

Investigating

Enterprise console may not be working as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted 10 months ago. Jun 18, 2024 - 14:07 UTC
This incident affected: Website.