Header for large screens Header for small screens

Pop up to sign in On Microsoft Office Files

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted Aug 30, 2025 - 10:01 UTC

Investigating

We are working with Microsoft to investigate this issue. Please close the pop up until fix a is implemented.
Posted Aug 29, 2025 - 19:17 UTC
This incident affected: Desktop Application.