System Status

"Invite" button not functioning properly
Incident Report for Dropbox
Resolved
We’re back! Thanks for bearing with us.
Posted Jan 08, 2020 - 21:37 UTC
Identified
We're experiencing an issue with the Dropbox Business team invitation flow where the "invite" button is not functioning properly. We've identified a fix and in the meantime entering a space or semicolon after the email address will solve the issue.
Posted Jan 08, 2020 - 20:35 UTC
This incident affected: Website.