System Status

Some users may experience issue signing in with Google Sign On
Incident Report for Dropbox
Resolved
The issue is now resolved. Google Sign On is fully functional for all users now. Thanks for your patience as we resolved the issue!
Posted 2 months ago. May 11, 2019 - 00:44 UTC
Identified
Authenticating through Google Sign On is not working for some users. We are working to resolve the issue and will update when we have more information.
Posted 2 months ago. May 10, 2019 - 22:15 UTC
This incident affected: Website, Desktop Application, and Paper.