System Status

Option to import directly from Google Drive is not currently functioning
Incident Report for Dropbox
Resolved
The option to import directly from Google Drive has been returned and is functioning. This incident has been resolved.
Posted Oct 23, 2023 - 21:11 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 23, 2023 - 16:33 UTC
Identified
The issue has been identified and the option will not appear for users until functionality has been returned.
Posted Oct 23, 2023 - 15:43 UTC
Investigating
Ability to import directly from Google Drive is not currently functioning. Our team is investigating the issue.
Posted Oct 23, 2023 - 15:07 UTC
This incident affected: Website.