Header for large screens Header for small screens

Dash Search might not be working for some users.

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted May 06, 2025 - 03:40 UTC

Investigating

Dash Search might not be working for some users. We are working to fix the problem as quickly as we can.
Posted May 05, 2025 - 21:38 UTC
This incident affected: Dash.