System Status

Sharing may not be working as expected
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Feb 10, 2023 - 21:41 UTC
Identified
We're investigating possible issues related to sharing.
Posted Feb 10, 2023 - 18:11 UTC
This incident affected: Website and Desktop Application.