System Status

Single Sign-On (SSO) may not be working as expected

Incident Report for Dropbox

Resolved

SSO is back up and running! Thanks for bearing with us.
Posted 11 months ago. May 14, 2024 - 00:14 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted 11 months ago. May 13, 2024 - 17:17 UTC

Investigating

Single Sign-On (SSO) may not be working as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted 11 months ago. May 13, 2024 - 15:31 UTC
This incident affected: Support Services.