System Status

DocSend unavailable
Incident Report for Dropbox
Resolved
Issue is resolved. Customers could have experienced errors or long load times from 14:21 to 14:24 UTC and 15:32 to 15:31 UTC
Posted Jan 22, 2025 - 15:52 UTC
Investigating
DocSend is currently unavailable, we are investigating the issue.
Posted Jan 22, 2025 - 15:45 UTC
This incident affected: DocSend.