Header for large screens Header for small screens

Option to import directly from Google Drive is not currently functioning

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted Sep 28, 2023 - 00:08 UTC

Identified

Ability to import directly from Google Drive is not currently functioning. The option will not appear for users until functionality has been returned.
Posted Sep 26, 2023 - 20:42 UTC
This incident affected: Website.