System Status

Search Results may not be working as expected
Incident Report for Dropbox
Resolved
The issue is now resolved
Posted Mar 03, 2022 - 00:07 UTC
Identified
We are aware of a degraded "Search Results" experience for new content recently added. We have improved the overall experience, and are working on fully resolving.
Posted Mar 02, 2022 - 21:26 UTC
This incident affected: Website.