Banner
Planned Site Maintenance
Incident Report for Dropbox
Resolved
Maintenance is now over
Posted about 2 years ago. Dec 05, 2015 - 18:21 UTC
Monitoring
Dropbox will be undergoing planned site maintenance for about 4 hours. For this period, you will be able to access your account and data, but will not be able to make changes. Your data will be safe throughout the maintenance, and will be available again right after this process ends.
Posted about 2 years ago. Dec 05, 2015 - 16:11 UTC