Header for large screens Header for small screens

Dropbox is experiencing some issues

Incident Report for Dropbox

Resolved

Thank you for your patience. This incident has been resolved.
Posted May 19, 2022 - 17:33 UTC

Investigating

We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted May 19, 2022 - 16:53 UTC