Header for large screens Header for small screens

Mobile web users may be experiencing errors with some of our web prompts

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted Oct 20, 2023 - 21:10 UTC

Investigating

Mobile web users may be experiencing errors with some of our web prompts. Our team is investigating the issue.
Posted Oct 20, 2023 - 20:42 UTC
This incident affected: Mobile Application.