System Status

Dropbox is not working for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Mar 23, 2023 - 15:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2023 - 15:09 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 23, 2023 - 15:00 UTC
Investigating
Dropbox is not working for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Mar 23, 2023 - 14:45 UTC
This incident affected: Website.