System Status

Dropbox may be unavailable for some users

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted May 02, 2025 - 02:07 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 02, 2025 - 01:29 UTC

Update

We are continuing to investigate this issue.
Posted May 01, 2025 - 22:38 UTC

Investigating

Dropbox may be unavailable for some users. We’re having some trouble with our services currently. We’re working to fix the problem as quickly as we can.
Posted May 01, 2025 - 21:57 UTC
This incident affected: Website, Desktop Application, Replay, and DocSend.