System Status

Dropbox.com is not working for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted May 12, 2023 - 23:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2023 - 23:32 UTC
Investigating
Dropbox.com is not working for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted May 12, 2023 - 23:27 UTC
This incident affected: Website.