Further issues with Paper
Incident Report for Dropbox
Resolved
Paper is back up and running. Sorry for the interruptions over the last number of days. Thanks for bearing with us.
Posted 6 months ago. Jun 21, 2018 - 11:33 UTC
Monitoring
We identified the new problem and a fix has been implemented. We're currently monitoring recovery but things should be coming back to a stable state for everyone. Sorry for any inconvenience.
Posted 6 months ago. Jun 21, 2018 - 10:52 UTC
Investigating
We're currently investigating the possibility of a new issue with Paper. It's likely that Paper is unavailable for all users. We'll share another update soon.
Posted 6 months ago. Jun 21, 2018 - 10:34 UTC
This incident affected: Paper.