System Status

We are currently experiencing a partial outage in Google editor
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted May 31, 2023 - 20:14 UTC
Update
We are continuing to work with Google to find a resolution. Thank you for your patience.
Posted May 31, 2023 - 16:26 UTC
Investigating
We are currently experiencing a partial outage in Google editor. We are working with Google to find a resolution. We expect that some users may not be able to open some Word, Excel, .gdoc or .gsheet files in the Google editor until this is resolved.
Posted May 30, 2023 - 21:37 UTC
This incident affected: Website and Mobile Application.