Dropbox is not working as expected for some users.

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 19:17 UTC

Update

We are continuing to investigate this issue.
Posted Sep 23, 2025 - 19:10 UTC

Investigating

We’re having some trouble with our services currently. We’re working to fix the problem as quickly as we can.
Posted Sep 23, 2025 - 18:55 UTC
This incident affected: Website, Desktop Application, Dash, and DocSend.