System Status

Dropbox is not working as expected for some users

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted 10 months ago. May 28, 2024 - 17:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 10 months ago. May 28, 2024 - 16:20 UTC

Investigating

We’re having some trouble with our services currently. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted 10 months ago. May 28, 2024 - 15:46 UTC
This incident affected: Website, Desktop Application, and Mobile Application.