System Status

Global intermittent connectivity
Incident Report for Dropbox
Resolved
We have identified and fixed the issue.
Posted Mar 24, 2020 - 17:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2020 - 17:09 UTC
Identified
We’re experiencing intermittent connectivity globally. We apologize for the inconvenience and our team is working to implement a solution as quickly as we can.
Posted Mar 24, 2020 - 17:00 UTC
This incident affected: Desktop Application.