Banner
Scheduled Maintenance
Incident Report for Dropbox
Resolved
Maintenance has concluded and Dropbox service has been fully restored. You may experience some latency with Dropbox tasks, but rest assured that normal performance will resume shortly. We apologize for any inconvenience this may have caused.
Posted almost 2 years ago. Nov 07, 2015 - 17:01 UTC
Monitoring
Dropbox will be in read-only mode during planned maintenance this morning. Thank you for your patience! We will update this page when the maintenance is complete.
Posted almost 2 years ago. Nov 07, 2015 - 16:29 UTC