System Status

Dropbox is not working as expected for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Nov 02, 2023 - 18:33 UTC
Update
We are continuing to investigate this issue.
Posted Nov 02, 2023 - 16:33 UTC
Investigating
Dropbox may be unavailable for some users. We’re working to fix the problem as quickly as we can.
Posted Nov 02, 2023 - 16:13 UTC
This incident affected: Website, Mobile Application, and API.